
scatterBrain (V 1.230) 

This document is a work in progress. Some scatterBrain features are yet to be documented, or have 

only been documented in a cursory manner. 
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Introduction 
scatterBrain is a software package developed at the Australian Synchrotron SAXS/WAXS beamline 

for data acquisition, data reduction, and initial data analysis. It serves as the main user interface for 

scientists conducting experiments at the Australian Synchrotron SAXS/WAXS beamline. A take home 

version is available for users to complete their data analyses after their beamtime has finished. 

scatterBrain is based on the SAXS15ID software originally written at the ChemMatCARS beamline of 

the Advance Photon Source Chicago. It is cross-platform compatible (Windows, Linux, OSX), and 

features a modern, drag-and-drop interface. 

Installing scatterBrain 

Preferred Installation 
The preferred installation of scatterBrain is straight forward: 

1. Download the Installation Package from: 

http://www.synchrotron.org.au/index.php/aussyncbeamlines/saxswaxs/software-saxswaxs  

This package is approximately 80 MB and contains a runtime distribution of IDL, compiled 

scatterBrain code (scatterBrainAnalysis.sav), a launcher, and various resource files. 

2. Unarchive the package to any preferred location 

3. Launch scatterBrain using the following launcher in the scatterBrainAnalysis directory:  

a. scatterbrainanalysis.exe for Windows 

b. scatterbrainanalysis .sh for Linux 

c. scatterbrainanalysis .app for OS X  

4. The first time scatterBrain is launched a hidden directory is created in your home folder. E.g., 

for windows this might be: 

c:\documents and settings\stephen\.idl\australiansynchrotron\scatterbrain-###-windows\ 

The scatterBrainSettings.xml file is stored in this directory, and contains “user preference” 

settings, and a recent file list. This file persists even with upgrades to scatterBrain. 

Alternative Installation 
In rare cases scatterBrain doesn’t launch when installed using the preferred method. Furthermore 

the “movie export” doesn’t work using the preferred installation method due to licensing 

restrictions. The following install is recommend if you require movie mode or have other installation 

issues. 

1. Complete steps 1 and 2 of the preferred installation method above 

2. Create an account at www.exelisvis.com . Account creation is free. 

http://www.synchrotron.org.au/index.php/aussyncbeamlines/saxswaxs/software-saxswaxs
http://www.exelisvis.com/


3. Download and install IDL from 

http://www.exelisvis.com/Downloads/Download.aspx?product=IDL . The download size is 

between 400 and 600 MB depending on your operating system. IDL can be downloaded for 

free. Precompiled code can be run without a license. A license is required only if you are 

writing your own IDL code. 

4. Launch scatterBrainAnalysis using scatterBrainAnalysis.sav – note that this is a different file 

to the one used in the preferred installation method. 

5. The scatterBrainSettings file mentioned above will also be created with this installation 

method. 

Upgrading scatterBrain 
Once installed, scatterBrain can be upgrade through the scatterBrain interface itself. In future 

versions you will be alerted of updates at started up. However, currently you manual check for 

updates using the option under the help menu. The update procedure usually just replaces the 

scatterBrainAnalysis .sav file which contains the actual code, however, larger updates may require 

the resource files to be updated or a new IDL distribution downloaded. You will be alerted of these 

larger updates through the scatterBrain interface and/or website. 

Starting scatterBrain 
Upon launching scattering you will be greeted with a window not unlike this (you won’t see this 

window if you have used the alternative installation method): 

 

http://www.exelisvis.com/Downloads/Download.aspx?product=IDL


Click on the scatterBrain Analysis button at the bottom centre to continue. You will then see yet 

another splash screen:

 

Click anywhere on this splash screen to continue. This second splash screen appears because we are 

using the IDL virtual machine. The only way to get rid of this is to buy an IDL license. 

scatterBrain will then open, as two windows. The image window: 

 

and the plot window: 



 

All screenshots in this document are from the Windows 7 version of scatterBrain, because it looks 

prettiest on that platform. scatterBrain looks terrible on Linux/OS X, but that is underlying issue with 

IDL that I hope they upgrade soon. Sigh... 

First Steps with scatterBrain 

The Experiment File 
To start looking at data with scatterBrain, you first must open a scatterBrain experiment. To load the 

experiment file: 

File->Get Experiment 

 



 An experiment file is in the XML format, and looks something like this:  

Zooming in on the important bits: 

 



 

This file contains all the configuration parameters required to generate the normalised 1D profiles, 

such as beamcentre, camera length and wavelength, masking, absolute intensity calibration, pixel 

size, etc. It is typically created at the start of the experiment by the beamline scientists, although it 

can be created at a later date, with the parameters determined from calibration shots. It is 

overwritten whenever it is saved inside scatterBrain, there is no automatic saving. To save: 

File->Save Experiment 

You can also save the experiment to a new file using: 

File->Save As Experiment 

Initially the experiment file doesn’t contain any information about the SAXS exposures (during an 

experiment this is stored in the live log, as explained in the next section), however, whenever the 

experiment is saved, the currently loaded log information is also saved into the experiment file. 

Hence, if you save the experiment with the full log file for your experiment loaded, in future you can 

forget about the log file. The experiment file also contains summed file normalisation parameters 

and detector parameters for running experiment. 

The Live Log File 
The Live log file is generated during data acquisition. It has an XML like format. Data is only ever 

appended to the file, it is never overwritten by the control system. A new line is added to the file 

with ever exposure, and many parameters are logged, but the most important is normalisation data. 

The file looks like this:  

 



As you can see each line has a timestamp, exposure time, normalisation parameters, information 

about sample table position, etc, along with the filename of the image collected. This file doesn’t 

contain information about the camera setup, etc, as this is also stored in the experiment file as 

described above. To load the live logfile: 

Acquire->Select Live Log 

 

During data acquisition at the beamline this file is being constantly updated, and scatterBrain will 

display these updates in real time. Anytime you save your experiment, the current state of the live 

log will also be saved into your experiment file. This means if you save your experiment file once you 

have collected all of your data, or if at a later date you open your experiment file and log file, and 

then save your experiment file, that the experiment file will then contain all of the information 

about your experiment. From that point forward you will not need to open the live log when you 

open your experiment. 

Loading Data 
After opening your experiment file (and possibly your live log file) the file list tree on the left hand 

side of the image window will be populated with a list of all the files known by the experiment 

(and/or log file). To load an image you: 

double-click it 

 or  

drag and drop it into the file tree on the Plot window 

The 2D image will be displayed on the main screen and the 1D azimuthally averaged plot will display 

on the plot screen. The image window will now look something like the following. Note the file list 

on the left: 



 

and after loading two images, the plot window may look like this: 

 

  



Plot Window  
The plot window has many features for displaying, using and generating 1-dimensional patterns, and 

is the window where most 1-d pattern operations are performed. 

Profile tree 
The profile tree is a list of all the 1-D patterns currently held in memory, and is shown on the right 

hand side of the plot screen.  

Subtracting Patterns 
Profile subtraction is done by drag and drop: DROP SAMPLE PROFILES ONTO BACKGROUND 

PROFILES. You can do multiple patterns at once by selecting them with shift-left click (for continuous 

files in the tree) or CTRL-left click (for discontinuous groups of files in the tree).The background 

pattern will stay at top level hierarchy in the profile tree and the subtracted sample pattern(s) will 

move to second level in the tree hierarchy (i.e. the sample profiles moving slightly to the right). The 

background will also now show a “-“ or “+” symbol which allows the sample profiles under each 

background to be sown or hidden in the tree listing. The plot window will now display the subtracted 



profile(s). Background  profiles will still be displayed by default, although you can hide individual 

profiles (either samples or backgrounds) using the profile tree context menu. 

To unsubtract a profile in the profile tree, just drag it off its background profile to anywhere in the  

blank (white) area of the profile tree. To change which background is subtracted from a sample 

profile, drag the sample profile from one background to another in the profile tree. 

Plot highlighting: If you click on one (or more) plots in the tree display, selected plots(s) will be 

highlighted with a thicker line style . This is a fast way to see which pattern is which on the main plot 

window when there are many pattern overlaid on screen. You can also move up/down in the plot 

tree using a keyboard (up/down keys) which can be more convenient than using a mouse. 

Axis scaling 
Linear/log axes. You can toggle the X and Y axes between linear and logarithmic scales using the 

bottons above the plot tree.  

Zoom in/out 
Left-drag a box on the main plot area, and the plot will zoom in to that area of the plot. To un-zoom, 

right click in the plot area and the plot will unzoom and autoscale. When new plots are added to the 

plot window, the axes hold their current scale ranges and do not autoscale: if the new plot doesn’t 

fit the current scale (e.g. you can’t see it at all) then right-click to autoscale. 

Profile tree context menu 
The context menu of the plot tree contains many functions which can act on existing profiles. Select 

the profile(s) you want to use with left-click, shift-left click or ctrl-left click, then 

Right-Click anywhere in the plot tree 

 and the context menu will appear. Most actions are self explanatory, so just some brief guidance: 

 Delete removes the profile from the profile tree, the plot area and from memory. It does not 

delete the original data (tif file). The “Delete All” button above the profile tree will delete all 

profiles. 

 Apply Parameters recomputes the profile, in order to apply any changes in camera parameters 

 Multiply and Offset allow you to apply multiplication or additive correction to a profile. The 

defaults are 1 and 0 respectively (i.e. no correction). If you have small subtraction errors these 

can be useful. Each correction is applied to whichever pattern(s) is selected before you apply the 

correction – normally you would want to only correct one profile at time. Any multiplication or 

addition terms for the currently selected profile are displayed below the profile tree. 

 Fit Peak fits a linear combination of a Gaussian peak and a linear background to the part of the 

currently selected profile (selected in the profile tree) which is displayed in the plot area. To fit a 

peak well you should normally zoom in on the peak first. Basic properties of the peak fit 

(position, width etc.) are temporally displayed at the bottom of the plot area. 

 Hide, Show and Show<>Hide allow you to hide a profile from the plot area without removing it 

from the profile tree, to re-display a hidden profile, or to toggle from one state to another. 

 Change Colour allows the profiles colour to be changed. A colour table dialog box appears for 

handling all plot colours. This is explained latter in this document. 



 Line Width and Opacity alter the line properties on the plot area. 

 Protein Tools allows some basic protein-specific data analysis to be run. Currently this allows 

Autoporod (ATSAS suite) to be run on one profile at a time (the last one selected). The fit data is 

displayed on screen and a temporary data file is written to the operating system’s temporary 

directory. 

Profile Window Menu Functions 

Save Profiles 

This menu item has two options for saving profiles to disk in a space delimited ASCII format. 

The first option 

Save ALL profiles to ONE large file 

saves all the currently plotted profiles into one single file. There are three columns of data for each 

profile, q vector, Intensity, Error in Intensity. The filenames for the each of the profiles is written 

above each set of data. When this menu item is selected a dialog box appears in order to select the 

file into which the data will be saved. The second option 

Save EACH file to individual profiles 

Saves a separate file for each profile plotted. These files have three columns each, q vector, Intensity 

Error in Intensity. When you select this option a dialog box appears for selecting the directory for 

output. The profiles will be saved into the files with the same name as the original data, with a .dat 

file extension. 

Note that both of these export functions honour any multiplicative and offset factors applied, as well 

as background subtraction. 

 

  



Intensity Normalisation and Calibration 

1. Delete all data from the plot window. 

2. From q-calibration, check the camera length is set correctly. The typical camera 

lengths for proteins are: 

 959 mm 

 1576 mm 

 3349 mm 

 7200 mm. 

Check photon energy is correct. 

We now use 11 000 eV: 12 keV is 

so last-year . If you need to 

change the camera length, type 

the correct length into both the 

"Calibrated Camera Length" and 

the "Current Camera Length" 

fields. If you make any changes, 

click "Apply Q Calibration", then 

close the window.   

 

 

3. Load your airshot 

 

4. Open the Intensity Normalsation 

and Calibration menu. 



5. Left click in the 

white space 

here 

6. Then select 

(click on) the 

air pattern here 

 

7. This will update the "New" Io, IBS 

and Ratio normalisation inputs. 

 

8. Then click "Apply Normalsation to 

IO/Beam Stop Counters" to make 

the new numbers "Current". Both 

rows of numbers need to match. 

 

  

9. Select the "Beamstop Intensity 

Normalisation" radio button 

10. Click Apply change of 

Normalisation button. 

 This will allow patterns to be normalised 

for incident and transmitted flux variation 

using the beamstop detector. 

11. Close the window. 

 

 



12. Delete the air pattern, and load the mtcap and water shots. 

 

13. Subtract the mtcap shots from the water shots (pairing up 1,2,5, and 10 second 

exposures). 

 

14. Load the "Intensity 

Normalisation and 

Calibration" Screen 

 

15. Click in the white 

space 

16. select all of the water shots (do not select the 

mtcap shots) 



17. Zoom in (left-drag box on plot screen) to select flat part of water calibration (if 

needed). 

18. You should see a plot that looks 

like this.  

19. Click on "Set Absolute Scaling". 

The tick box next to "Use Absolute 

Calibration will come on. A small 

scale factor offset (eg between ± 

0.1 is OK). In V1.61, ignore status 

of normalisation mode at this point 

in the procedure (don't change it). 

There is a bug in the code making 

the current norm state not display 

correctly just  at this part of the 

calibration sequence which will be 

eliminated in next version. 

 

20. Close the window. 

21. Delete all the patterns in the plot window and re-load air, mtcap and water shots. Subtract 

mtcap from water shots, and check you are happy with th results. The flat part of the 

water pattern (when its mtcap background is subtracted)  must be close to 0.0163 cm 
-1

. If 

not, repeat software calibrations. If this is still wrong then you may need to re-collect 

data.  You are also looking for an acceptably clean subtraction at low q, i.e. the subtracted 

water pattern is flat and doesn't tail up of down too much - how much depends on what 

scattering intensity you are then going to use, which depends on protein size, scattering 

power and concentration. The following is an good calibration data set at 3.3 m camera 

length: 

 



22. Save the configuration (to RAM) 

by clicking "Save" button here.  

23. Save experiment file to disk 

using "File/Save Experiment" or 

"File/Save Experiment As". 

  



Q Calibration 

This menu item opens a new window for energy/wavelength/camera length calibration.  

 

The beam energy or wavelength is entered/altered with the keyboard (these fields are linked, so you 

only have to fill in one). 

To use a calibration standard to set the camera length, you first load a measured pattern, zoom in to 

just a single peak in the plot area, right-click on that profile in the profile tree and select: 

Fit Peak 

The Fitted Peak Position will be updated in the Q Calibration GUI, and then the camera length will be 

calculated based on the reference standard (e.g. Silver Behenate, rat tail tendon, LaB6 or a user-

configured standard) and the diffraction peak order currently selected from the drop-down lists. You 

can change standards and/or peaks as needed and the camera length will be re-calculated. The 

calculated (i.e. calibrated) camera length is shown in the “Calibrated Camera Length” box, and the 

actual camera length currently being used for q-scaling is shown in the “Current Camera Length”. To 

apply the new calibration (to the Configuration(s) selected in the configuration drop-down (often 

just use “All”) click the  

Apply Q Calibration 

 button. This will update the camera length used for q-scaling and close the Q-calibration window. If 

you wish to use this window to only change the energy, without changing the camera length, make 

sure that the  

Calibrated Camera Length 

Is set to be the same as the 



Current Camera Length 

before applying. 

  



Image Window 
Is the nerve centre of scatterBrain. Not only does it display the image data, but includes the File 

Tree, tools for determining beamcentre, setting masks, as well as displaying the main program 

menu. 

Main Program Menu 
The main program menu has several 

File 

Acquire 

Tools 

Several tools are accessible from this menu item. The 

Tools->Export Image->Export Current Image 

Command exports the currently loaded image into a format that is convenient for viewing and 

printing. Typical file formats such as JPEG and PNG are offered. The exported file has the same 

colour table and scaling applied as the image in the image window. Note that these exported images 

have much less information encoded in them as the original data, as the bit depth is reduce from the 

native 32bits in order to view on screen or print. 

Tools->Export Image->Export Current Image with Annotations 

Is the same as above but also includes masking and beamcentre annotations. 

The  

Convert SAXS15ID log/saxs files to scatterBrain experiment 

Allows data generated using SAXS15ID to be converted for use in scatterBrain. 

Settings 

Settings->General Settings 

Command opens a window with many general settings available for scatterBrain. These include 

 Pixel Bins – The number of pixel widths per histogram bin. Typically this should be set to 1 or 

2. 

 Number of Sectors – The number of sectors to use in a sector integration. 

Control Tabs 
The control tabs on the right hand side of the image window, enable access to various functions and 

information. 

File Tree 


